Friday 21 June 2013

unix utils translation

I've been jumping back and forth between a few OSes lately and I keep typing the wrong thing at the prompts for day to day admin.  So I'm putting it here so I don't forget :-)

This is the commands for general update current packages, install new packages etc type stuff

Gentoo Linux:

update: emerge --sync && emerge -DuN --keep-going world
install:  emerge --sync && emerge packagename
search:  emerge --sync && emerge -s name
or emerge --sync && emerge --searchdesc

FreeBSD (9.1 if it makes a difference)

packages (pre-compiled)

update: freebsd-update --

and for ports (from source)

update: portsnap fetch update && portupgrade -a
install: cd /usr/ports/catagory/package && make WITH_LDAP="YES" install clean


Centos 6.3

update: yum check-update && yum update
install: yum install packagename
search: yum search 

More to come..

Control break on an RDP session from a Mac keyboard

Found this by accident.  I was trying to do a control break to show ping statistics.

If you do control F13 F14 quickly it does a control break.  Control F13 by self didn't but if you keep control down and do F14 as well it shows me the ping stats and carries on as you'd expect. I did get it to work once with just a few control F13s but couldn't confirm that one.

Hope that save some time for someone..

Gentoo grub-probe not working

 I have a bunch of history commands I run when I d a new kernel etc and one stopped working. grub-mkconfig would fail with grub-probe for /....